Home
Scripts
Contributions (Pro Mod Access)
FAQ's
Downloads
Support Forum
  SnailSource.com [Logo]
Calendar LiteCalendar Lite (Demo)
Calendar ProCalendar Pro (Demo)
LinksLinks Pro (Demo)
Log in to check your private messagesForum
RegisterRegister
Log inLog in
Log in to check your private messagesLog in to check your private messages SearchSearch FAQFAQ ProfileProfile MemberlistMemberlist UsergroupsUsergroups Join GroupsJoin Groups

Could not select Gallery permission after upgrade 2.0.18
Goto page 1, 2  Next
 
Post new topic   Reply to topic   printer-friendly view    SnailSource.com Forum Index -> Gallery->phpBB2 Integration Support printer-friendly view
View previous topic :: View next topic  
Author Message
zeo



Joined: 03 Oct 2002
Posts: 5



Hlp* 9.10
PostPosted: Mon Oct 31, 2005 3:37 am    Post subject: Could not select Gallery permission after upgrade 2.0.18 Reply with quote Direct link

I just finish upgrading my phpbb board to the newly 2.0.18 version.
As usual i browse to all pages including gallery.
then I ran into gallery sql error.

i thought u might know
Quote:

Could not select Gallery permission from user table

DEBUG MODE

SELECT user_gallery_perm FROM phpbb_users WHERE user_id = ''

Line : 127
File : User.php


Thank in advance.
Back to top
View user's profile Send private message
Martin
Site Admin


Joined: 24 Mar 2002
Posts: 8182



Hlp* 3655.72
PostPosted: Mon Oct 31, 2005 9:45 am    Post subject: Reply with quote Direct link

Thanks for the heads up... I'll check it out...

Most likely there's some changes in the code that have hidden some data.
Back to top
View user's profile Send private message
zeo



Joined: 03 Oct 2002
Posts: 5



Hlp* 9.10
PostPosted: Mon Oct 31, 2005 1:42 pm    Post subject: Reply with quote Direct link

Wow thanks for the support.
Hope it will be done soon.

I found these in apache errorlog,

Code:
[Mon Oct 31 20:14:50 2005] [error] PHP Warning:  mysql_connect(): Access denied for user: 'user@localhost' (Using password: NO) in /www/forum/modules/gallery/classes/database/mysql/Database.php on line 28


seems it can query database passwd.
Back to top
View user's profile Send private message
Martin
Site Admin


Joined: 24 Mar 2002
Posts: 8182



Hlp* 3655.72
PostPosted: Mon Oct 31, 2005 7:00 pm    Post subject: Reply with quote Direct link

Ok, the problem is caused by this line...

common.php

Find:
Code:
// We do not need this any longer, unset for safety purposes
unset($dbpasswd);


Replace with:
Code:
// We do not need this any longer, unset for safety purposes
//unset($dbpasswd);


Technically this reduces the security level this "fix" was intended to increase but unless you do it, gallery won't work anymore without you switching over to using the phpBB2 db module.
Back to top
View user's profile Send private message
zeo



Joined: 03 Oct 2002
Posts: 5



Hlp* 9.10
PostPosted: Tue Nov 01, 2005 1:40 am    Post subject: Reply with quote Direct link

It seems good enough instead using a blank mysql password.

Thanks mate. Cool
Back to top
View user's profile Send private message
rog



Joined: 15 Dec 2005
Posts: 2



Hlp* 3.00
PostPosted: Sun Dec 18, 2005 1:45 pm    Post subject: Reply with quote Direct link

I'm not sure if I should start a new topic for this question (apologies if I should have) ...

I'm getting the exact same error reported above with Gallery 1.5.1 and phpBB 2.0.4 (both of which are working fine independently). There is no such line to comment out as suggested in the solution within my common.php file.

Also, the web error.log is slightly different, we're using postgres for the database, which i think may be part of the problem in this case ...

[client ---ip---] PHP Warning: mysql_connect(): Access denied for user: '---user---@localhost' (Using password: YES) in /var/www/--- gallery path---/docroot/classes/database/mysql/Database.php on line 28

Any ideas?

Many thanks in advance,
- Rog
Back to top
View user's profile Send private message
Martin
Site Admin


Joined: 24 Mar 2002
Posts: 8182



Hlp* 3655.72
PostPosted: Sun Dec 18, 2005 8:09 pm    Post subject: Reply with quote Direct link

rog wrote:
I'm not sure if I should start a new topic for this question (apologies if I should have) ...

I'm getting the exact same error reported above with Gallery 1.5.1 and phpBB 2.0.4 (both of which are working fine independently). There is no such line to comment out as suggested in the solution within my common.php file.

I hate to say this but it's applicable, you should not under any circumstances be running 2.0.4 of phpBB2... You are leaving yourself WIDE open to hacking, etc...

UPGRADE!!

I really can't help until you are up to date....
Back to top
View user's profile Send private message
rog



Joined: 15 Dec 2005
Posts: 2



Hlp* 3.00
PostPosted: Sun Dec 18, 2005 10:44 pm    Post subject: Reply with quote Direct link

Ok, thanks. I'll talk to the guy that installed the forum side of things, He's gonna hate it (we've got lots of customisations), but you're right, we should keep up to date.

Thanks,
- Rog
Back to top
View user's profile Send private message
Martin
Site Admin


Joined: 24 Mar 2002
Posts: 8182



Hlp* 3655.72
PostPosted: Wed Dec 28, 2005 1:37 pm    Post subject: Reply with quote Direct link

rog wrote:
Ok, thanks. I'll talk to the guy that installed the forum side of things, He's gonna hate it (we've got lots of customisations), but you're right, we should keep up to date.

Yep.. I can't say I blame him at all as it's likely that he'll have to start from scratch and reinstall many of them. Nature of the beast unfortunately.

I can recommend that he seriously consider using a tool like examdiff and if he has the time to learn, a CVS or SubVersion server to track changes in his own code. I use it to great effect myself on all my mods.

Best of luck.
Back to top
View user's profile Send private message
Saratoga Sam



Joined: 14 Feb 2004
Posts: 112
Location: Silicon Valley


Hlp* 111.06
PostPosted: Mon Jan 02, 2006 5:49 am    Post subject: Reply with quote Direct link

Martin -

Thanks for the fix. I just upgraded and ran into this problem.

Saratoga Sam
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic   printer-friendly view    SnailSource.com Forum Index -> Gallery->phpBB2 Integration Support All times are GMT + 1 Hour
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

This board is protected by Phpbbantispam
Board Security

15557 Attacks blocked

Powered by phpBB © 2001, 2005 phpBB Group